Innehåll

Innehåll Styrteknik Grundkurs

Introduktion till LearnWARE® Styrteknik Grundkurs

Övningar

Fakta

I/O-listor


Introduktion

Styrteknik Grundkurs

Styrteknik GrundkursÔ är ett kursanpassat paket med Optimalt elev och lärarstöd. Paketet består av ledtext som skall leda eleven genom de olika övningarna, multimedia-funktioner, parat mer vår välkända Äkta Simulering. Denna kombination ger lärarna inom industrin, i gymnasieskolan och AMU-gruppen ett modernt verktyg att använda i utbildningen. Styrteknik GrundkursÔ är ett ypperligt verktyg för den som vill sköta sin utbildning på egen hand.

Paketet består av ett flertal olika Övningar som kursdeltagaren skall gå igenom.


Övningar

Övning 1

Övning 2

Övning 3

Övning 4

Övning 5

Övning 6

Övning 7

Överkurs


Faktainnehåll

Automation, elektroniken

Automation, komponenter

Automation, varför?

Cyklisk bearbetning

Dokumentation

Elschema

Felorsaker

Felsökning

Förregling

Instuktionslista

Ladderschema

Logikproblem

Logikschema

Logiska funktioner

Maskinstyrning

Modern Produktion

Peas & Lav

PLC

Pneumatiskt schema

Processtyrning

Programkonstruktion

Programmering via PC

Sekvensproblem

Sensorer

Symbolspråk, användningsområden

Säkerhet i PLC-program

Tillverkning


I/O-listor

Cylinderplatta

Fyrvägskorsning

Kulsorterare

Trafikljus

Övergångsställe


Övergångsställe

Melsec FX Siemens S7

Ingångar Kommentar

X0 I0.0 Tryckknapp för fotgängare bortre

X1 I0.1 Tryckknapp för fotgängare hitre

X2 I0.2 Knapp för service

X3 I0.3 Magnetslinga för bilar hitre

X4 I0.4 Magnetslinga för bilar bortre

Utgångar Kommentar

Y0 Q1.0 Rött ljus för bilar

Y1 Q1.1 Gult ljus för bilar

Y2 Q1.2 Grönt ljus för bilar

Y3 Q1.3 Rött ljus för fotgängare

Y4 Q1.4 Grönt ljus för fotgängare


Överkurs

Som en extra uppgift kan du här programmera ett PLC-system som övervakar trafiken i en fyrvägskorsning.


Övning 1

Den absolut största användningen av styrtekniska komponenter står industrin för. I denna övningen tittar du på hur industriell tillverkning går till, och vilka apparater och komponenter som krävs för detta. Du ska se var de sitter, hur de är hopkopplade och vilka funktioner de har.


Övning 2

För att få de olika styrdonen, cylindrar och motorer, att agera i rätt ögonblick måste det finnas överordnad logik som ser till detta. Genom att bygga samman ett antal logiska funktioner kan man se till att styrdonen agerar på ett korrekt sätt. I denna övningen ska vi titta på hur dessa olika logiska funktioner fungerar, och i nästa övning ska vi titta på hur dessa utförs i PLC:t.


Övning 3

I denna övningen ska vi titta på hur logiska funktioner programmeras in i ett PLC . För att göra detta måste vi lära oss PLC-språket, dvs det språk som PLC:t använder. För att programmera ett PLC måste vi alltså översätta från vårt mänskliga språk till det språk som PLC:t använder. När du skall programmera ditt PLC i denna övningen kommer du att göra det i en PLCeditor.


Övning 4

PLC används till de mest skiftande ändamål inom industri och andra näringsgrenar. Vi ska här titta på ett exempel, ett PLC styr ett trafikljus.


Övning 5

PLC:t övervakar trafiken i en trafikkorsning. Ett övergångsställe som trafikeras av gående och bilar ska styras.


Övning 6

Sensorns uppgift är att snabbt reagera och ge signal när något inträffar. Den reagerar genom att skicka en elektrisk signal till PLC:t. Med styrdonens hjälp kan PLC:t påverka sin omgivning. Exempel på styrdon är cylindrar och motorer. I denna övning ska vi titta lite närmare på några sensorer och styrdon.


Övning 7

PLC:t ska styra en kulsorteringsmaskin , denna har till uppgift att sortera kulor av olika material, glaskulor respektive metallkulor.


ANB-instruktinen, A(

ANB-instruktionen (Melsec FX)

Denna instruktion används för att seriekoppla de olika programblocken i ditt PLC-program.

Funktionen tar logiskt och mellan det båda senaste blocken.Detta används för att lösa uppgifter där de "vanliga" funktionerna inte räcker. För att påbörja ett block används LD och LDI

Se även: AND ANI ORB

A(-instruktionen (Siemens S7)

Denna instruktion används för att seriekoppla de olika programblocken i ditt PLC-program.

För att påbörja ett block används A(. Blocket avslutas sedan med ).

Se även: A , AN , O(


AND-instruktionen, A

AND-instruktionen (Melsec FX)

Kontakterna efter LD benäms efter den logiska funktion man önskar, exempelvis AND om man vill ha en OCH-funktion.

Om man vill invertera en signal skall man använda LDI respektive ANI i stället.

Se även: OR ORI OUT ANB

A-instruktionen (Siemens S7)

A-instruktionen används för att seriekoppla en kontakt med föregående kontakt, dvs för att skapa en OCH-funktion.

Om man vill invertera en signal skall man använda AN i stället.

Se även: O ON = A(


ANI-instruktionen, AN

ANI-instruktionen (Melsec FX)

ANI betyder AND Inverse. Om en av de seriekopplade kontakterna INTE skall vara Till för att utgången skall bli Till använder man instruktionen ANI.

Se även: LDI AND ORI

AN-instruktionen (Siemens S7)

AN betyder AND Not. Om en av de seriekopplade kontakterna INTE skall vara Till för att utgången skall bli Till använder man instruktionen AN.

Se även: A ON


Automation, elektroniken

En av de saker som betytt mest för den industriella utvecklingen är elektroniken. Med hjälp av denna har man kunnat ta fram apparater som datorer, telefoner m.m vilka har gjort den industriella tillverkningen effektivare och bättre.


Automation, komponenter

Ordet automation står för den teknik och de metoder som används för att göra industriell tillverkning mer effektiv och mer miljövänlig. Här följer några komponenter som krävs i industriell automation:

l Sensorer

l Pneumatiska cylindrar

l Magnetventiler, Riktningsventiler

l PLC, Programmable Logic Controller, en industriell dator som styr tillverkningen

l Motorer

l Kontaktorer , som används för att styra motorerna


Automation, varför?

Människan har alltid lagt mycket energi på att förbättra sina livsvillkor. Man har uppfunnit verktyg och metoder som har gjort livet lättare att leva. Sedan industrialismens intåg i slutet av 1800-talet har det också handlat om att kunna tillverka så många produkter som möjligt, till så låg kostnad som möjligt. På senare år har man dessutom försökt att göra detta arbetet utan att smutsa ned vår miljö alltför mycket. Detta arbete har varit mycket framgångsrikt, i varje fall i den svenska industrin.

I princip kan man säga att det finns tre orsaker till att människan gör förändringar i sitt arbete eller i sin vardag, man vill:

l Underlätta arbetet

l Tjäna mer pengar

l Få en bättre miljö


Cyklisk bearbetning

Denna benämning anger hur ett PLC utför sitt arbete. Arbetet sker i 3 steg:

Inläsning av ingångarnas status till den interna processavbilden (internt minne i PLC:t).

Körning av PLC-programmet. Här utförs instruktion för instruktion av programmet, och resultatet av varje instruktion hamnar i processavbilden.

Utläsning till utgångarna, processavbilden läses ut till utgångarna. Utgångar som ska vara Till sätts Till osv.

Ett annat ord för cyklisk bearbetning är I/O-kopiering. Ett varv i ett normalt PLC tar cirka 5 millisekunder.


Cylinder

Enkelverkande cylinder

En cylinder som med hjälp av ett fjädersystem rör sig själv i ena riktningen. I ena riktningen måste den tillföras luft för att röra sig, men i andra riktningen rör den sig själv, även om man inte tillför luft.

Dubbelverkande cylinder

En cylinder som tillförs luft i båda riktningarna och endast rör sig om luft tillförs. För att få den att röra sig i ena riktningen tillför man luft till ena kammaren, för att få den att röra sig i andra riktningen tillför man luft till andra kammaren.


Cylinderplatta

Dubbelverkande cylinder

Melsec FX Siemens S7

Ingångar Kommentar

X0 I0.0 Plusläge

X1 I0.1 Minusläge

Utgångar Kommentar

Y0 Q1.0 Kolv plusrörelse

Y1 Q1.1 Kolv minusrörelse

Enkelverkande cylinder

Melsec FX Siemens S7

Ingångar Kommentarer

X2 I0.2 Plusläge

X3 I0.3 Minusläge

Utgångar Kommentarer

Y2 Q1.3 Kolv plusrörelse


Dokumentation

Ett annat ord för dokumentation är Ritningsunderlag, dvs de ritningar som beskriver anläggningen. Det kan vara pneumatiska ritningar, elektriska ritningar, placeringsritningar men också vara PLC-program, Ladder-schema etc.


ELLER-funktionen

På engelska heter denna OR , och innebär att man parallellkopplar kontakterna.

Ett annat sätt att uttrycka ELLER-funktionen; om alla ingångarna är Från är utgången Från, annars är den Till.

Se även OCH-funktionen


ELLER-funktionen i PLC-språk

(Melsec FX)

En ELLER- funktion i Mitsubishis PLC görs på detta sätt:

LD X2

OR X3

OUT Y6

Detta är en ELLER-funktion mellan ingångarna X2 och X3. Om någon av dessa bägge är Till, eller en av dem är Till, sätts utgång Y6 Till.

(Siemens S7)

En ELLER- funktion i Simens PLC görs på detta sätt:

O I0.2

O I0.3

= Q1.6

Detta är en ELLER-funktion mellan ingångarna I0.2 och I0.3. Om någon av dessa bägge är Till, eller en av dem är Till, sätts utgång Q1.6 Till.


Elschema

Hur de olika komponenterna är hopkopplade, givare, PLC och styrdon, beskrivs i ett Elschema. Hur dessa symboler ska se ut finns beskrivet i standarder och du kan se hur de ser ut i bilden. Numreringen på PLC:ts in- och utgångar kan vara lite olika på de olika PLC-fabrikaten. I Mitsubishis PLC numreras ingångarna löpande med ett X framför, exempelvis X0, X1, X2 osv. Utgångarna numreras löpande med ett Y framför, Y1, Y2, Y3 osv.

I Siemens PLC numreras ingångarna löpande med ett I framför, exempelvis I0.0, I0.1, I0.2 osv. Utgångarna numreras löpande med ett Q framför, Q0.1, Q0.2, Q.3 osv.
I elschemat beskrivs alltså till vilka ingångar som elkopplarna är kopplade på PLC:t, och till vilka utgångar som kontaktorer och ventiler är kopplade.


END-instruktionen

END-instruktionen (Melsec FX)

END instruktionen skriver man sist i PLC-programmet. När PLC:t kommer till END instruktionen slutar den att läsa här, detta innebär att PLC:t inte läser de tomma programraderna som kommer efter.

Exempelvis: Om du har ett PLC som har tillgång till 1000 programrader, och du skriver ett kort PLC-program som består av fyra rader och END instuktionen är med då slutar PLC:t att läsa på END instruktionen. Om inte END instruktionen är med läser PLC:t alla 1000 programraderna.

LD X0

AND X1

OUT Y0

END


Fördröjnings-funktionen i PLC-språk

Melsec FX

En fördröjningsfunktion görs så här:

LD X3

OUT T0

K50

LD T0

OUT Y5

Denna fördröjning (fördröjning T0, det finns flera hundra!) fördröjer tillslaget av utgång Y5 med 5 sekunder efter det att ingång X3 blivit Till. Denna fördröjningsfunktion kallas för tillslagsfördröjning, den fördröjer tillslaget av utgång Y5.

Siemens S7

En fördröjningsfunktion görs så här:

A I0.3

L S5T#5S

SD T0

NET

A T0

= Q1.5

Denna fördröjning (fördröjning T0, det finns flera hundra!) fördröjer tillslaget av utgång Q1.5 med 5 sekunder efter det att ingång I0.3 blivit Till. Denna fördröjningsfunktion kallas för tillslagsfördröjning, den fördröjer tillslaget av utgång Q1.5.


Fördröjningsfunktion

Denna funktion kallas med ett annat ord för Timer, dvs tidtagarur. Den används för att mäta tid. Det finns två typer av fördröjningar, Tillslagsfördröjning och Frånslagsfördröjning.

Tillslagsfördröjning

Frånslagsfördröjning


Förregling

Ett namn på de funktioner man inför för att undvika farliga lägen. Det kan exempelvis vara instruktioner i PLC-programmet som gör att en viss cylinder inte får röra sig om inte dess givare är påverkad. Detta kallar man att man har förreglat cylinderns rörelse.


Felorsaker

De vanligast felorsakerna i PLC-styrda anläggningar är:

1. Felkoppling, dvs någon har gjort en förändring någonstans, och kopplat ihop anläggningen på ett felaktigt sätt. Detta gör att du alltid ska kontrollera om någon har arbetat i anläggningen strax innan felet inträffade.

2. Apparatfel, dvs givare, PLC, styrdon etc har havererat. Sådan fel hittar du enklast genom att studera displayer, lysdioder etc på respektive apparat.

3. Processfel, vilket kan innebära mekaniska förslitningar i pumpar och andra apparater som hör till processen/maskinen. Denna typ av fel kräver att du är bekant med hur processen fungerar, inte bara hur ett PLC fungerar.


Felsökning

Chansen att hitta ett fel i en anläggning ökar om du använder en Felsökningsmetod. En enkel sådan kan vara:

1. Försök konstatera om felet sitter hos någon givare (sensor), i PLC:t eller hos något av styrdonen. Det är sällan som det är fel i PLC:t, oftast finns felen på givarsidan!

2. Studera PLC:ts alla lysdioder, ser de normala ut? Finns det någon lysdiod som indikerar att matningsspänningen har fallit bort osv?

3. Kontrollera alla matningsspänningar, till skåp, till PLC:t och på alla de ställen där du kan tänka dig finna matningar. Detta är ett vanligt fel!

4. Om man trots detta inte hittat felet är det dags att börja använda en systematisk metod. Denna går ut på att mäta signalspänningar mellan exvis PLC och styrdon, mellan givare och PLC osv. Börja mät mitt i denna kedja, och sök dig sedan åt det håll som inte har korrekt signalvärde. På detta sätt hittar du oftast felet på kortast tid.

I tillverkarens manualer hittar du oftast också en felsökningstabell, en tabell som visar de vanligaste felen på just detta systemet. Detta är en bra hjälp!

De viktigaste instrumenten för dig när du söker fel är:

1. En systematisk metod.

2. Tålamod.

3. Ett serviceinstrument att mäta signaler etc med.


Frånslagsfördröjning

Frånslagsfördröjning innebär att frånslaget av exempelvis en utgång fördröjs.

Exempel: om man vill att utgång Y5 ska bli Från 5 sekunder efter det att ingång X2 har blivit Från, ska man använda en Frånslagsfördröjning.

Se även: Tillslagsfördröjning


Fyrvägskorsning

Melsec FX Simens S7

Ingångar Kommentarer

X0 I0.0 Tryckknapp1 (väg1)

X1 I0.1 Tryckknapp2 (väg1)

X2 I0.2 Tryckknapp3 (väg1)

X3 I0.3 Tryckknapp4 (väg1)

X4 I0.4 Magnetslinga1 (väg1)

X5 I0.5 Magnetslinga2 (väg2)

X6 I0.6 Magnetslinga3 (väg3)

X7 I0.7 Magnetslinga4 (väg4)

Utgångar Kommentarer

Väg 1

Y0 Q1.0 Grönt ljus för bilar

Y1 Q1.1 Gult ljus för bilar

Y2 Q1.2 Rött ljus för bilar

Y14 Q3.0 Grönt ljus för gångtrafikanter

Y15 Q3.1 Rött ljus för gångtrafikanter

Väg 2

Y3 Q1.3 Grönt ljus för bilar

Y4 Q1.4 Gult ljus för bilar

Y5 Q1.5 Rött ljus för bilar

Y16 Q3.2 Grönt ljus för gångtrafikanter

Y17 Q3.3 Rött ljus för gångtrafikanter

Väg 3

Y6 Q2.0 Grönt ljus för bilar

Y7 Q2.1 Gult ljus för bilar

Y10 Q2.2 Rött ljus för bilar

Y20 Q3.4 Grönt ljus för gångtrafikanter

Y21 Q3.5 Rött ljus för gångtrafikanter

Väg 4

Y11 Q2.3 Grönt ljus för bilar

Y12 Q2.4 Gult ljus för bilar

Y13 Q2.5 Rött ljus för bilar

Y22 Q3.6 Grönt ljus för gångtrafikanter

Y23 Q3.7 Rött ljus för gångtrafikanter


Induktiv sensor

Den induktiva sensorn reagerar endast på metallföremål. Anledningen till det är att metallföremål förändrar det magnetfält som den induktiva sensorn bygger upp. Sensorn märker förändringen och ändrar sin utsignal. Utsignalen kan ändras på två sätt beroende på om det är en PNP- eller NPN-sensor. En PNP-sensor ger en positiv utsignal och en NPN-sensor ger en negativ. Mätavståndet för en induktiv sensor är 1.5 - 15 mm. Den induktiva sensorn är mindre känslig för nedsmutsning än den kapacitiva och optiska sensorn.


Instuktionslista

Instruktionslista

Detta är det språk som PLC:t använder. Man programmerar PLC:t genom att ange i vilken ordning ett antal instruktioner ska utföras. Som programmerare måste man ha detaljkunskap om hur PLC:t arbetar och veta exakt vad man vill åstadkomma. Om dessa villkor är uppfyllda är detta ett bra sätt att programmera PLC, men det kräver mer erfarenhet och ger dessutom sämre överblick än de grafiska motsvarigheterna Ladder och Funktionsblock.

Varje instruktion i ett PLC-program består av en Operation och en Operand, exempelvis AND X4. AND är i detta fall operation och anger vad som ska utföras, en OCH-funktion (AND på engelska). Operanden X4 anger på vilken ingång (X4) operationen ska utföras.


INTE-funktionen

Inte heter NOT på engelska, och innebär att man gör en Invertering. Om insignalen är Till blir utsignalen Från. Om insignalen är Från blir utsignalen Till.

Melsec FX

I PLC:t löses detta genom att de inverterade varianterna LDI ANI samt ORI används

Siemens S7

I PLC:t löses detta genom att de inverterade varianterna AN samt ON används.


INTE-funktionen i PLC-språk

Melsec FX

En INTE- funktion i Mitsubishis PLC görs på detta sätt:

LDI X3

OUT Y4

Detta är en INTE-funktion på ingången X3. Om denna är Från sätts utgång Y4 Till. Om X3 är Till blir utgång Y4 Från.

Siemens S7

AN I0.0

= Q1.2

Detta är en INTE-funktion på ingången I0.0. Om denna är Från sätts utgång Q1.2 Till. Om I0.0 är Till blir utgång Q1.2 Från.


JA-funktionen

Denna funktion är den enklaste av dem alla! Om insignalen är Till så är utsignalen Till. Om insignalen är Från så är utsignalen Från.


Kapacitiv sensor

Den kapacitiva sensorn reagerar på alla föremål. Sensorn bygger upp ett elektriskt fält vilket förändras när något föremål kommer in i det. Sensorn märker förändringen och ändrar sin utsignal. Utsignalen kan ändras på två sätt beroende på om det är en PNP- eller NPN-sensor. En PNP-sensor ger en positiv utsignal och en NPN-sensor ger en negativ. Mätavståndet för en kapacitiv sensor är 3 - 25 mm. Den kapacitiva sensorn är känslig för nedsmutsning då den reagerar på allt.

Se även: induktiv sensor .


Kontaktor

Används för att starta och stoppa motorer. Genom att ge kontaktorn signal kan denna fås att starta en motor genom att tillföra spänning till denna. Om den inte får signal så stoppas motorn. En kontaktor är i de flesta fall unistabil, dvs om den inte får signal så återgår motorn till sitt stoppläge.


Kulsorterare

Melsec Fx Siemens S7

Ingångar Kommentar

X0 I0.0 Skyttelcylinder höger läge

X1 I0.1 Skyttelcylinder mittläge

X2 I0.2 Skyttelcylinder vänster läge

X3 I0.3 Höger utstötare minusläge

X4 I0.4 Vänster utstötare minusläge

X5 I0.5 Induktiv sensor, metallavkänning

X6 I0.6 Fotoelektrisk sensor, kulavkänning

X7 I0.7 Höger utstötare plusläge

X10 I1.0 Vänster utstötare plusläge

Utgångar Kommentar

Y0 Q1.0 Skyttelcylinder höger

Y1 Q1.1 Skyttelcylinder vänster

Y2 Q1.2 Cylinder höger utstötare

Y3 Q1.3 Cylinder vänster utstötare


Ladderschema

Ett av de vanligaste symbolspråken för att programmera PLC. Genom att sätta ihop kontakter genom serie- och parallellkoppling kan man utföra de vanligaste logiska funktionerna OCH, ELLER och INTE. Dessutom finns också Fördröjningsfunktioner, Räknefunktioner och Minnesfunktioner att tillgå.

När man beskrivit önskad funktion i ett Ladderschema är det ganska enkelt att översätta detta till PLC-instruktioner.


LDI-instruktionen

(Melsec FX)

Om man efterfrågar att kontakten inte skall vara Till brukar man kalla detta att man vill ha inverterad signal. Om man vill börja ett logiskt block med en inverterad signal skriver man LDI, Load Inverse.

(Siemens S7)

Om man vill börja ett logiskt block med en inverterad signal skriver man AN eller ON.


LoaD-instruktionen

LD-instruktionen (LoaD)

(Melsec FX)

Översättningen av Ladderschema eller Funktionsblock till PLC-program görs kontakt för kontakt och kopplar dessa till en utgång som ska påverkas. Den första kontakten översätts alltid med LD i Mitsubishis PLC.

Se även: LDI

(Siemens S7)

I Siemens S7 startar man med instruktionen A eller O .


Logikproblem

Detta är det namn man brukar använda på de styrproblem som ska styras utan att man behöver ta hänsyn till vad som hänt innan, dvs de ska inte styras i sekvens. Exempel: Lampan ska tändas när man trycker på en speciell knapp. Man bryr sig inte om vilka åtgärder som vidtagits innan. Jämför med sekvensproblem.


Logikschema

Tillsammans med Ladder-schema har denna schematyp använts under många år för att programmera PLC. Detta symbolspråk är också grafiskt, liksom Ladder, men byggs upp på ett annat sätt. Istället för att som i Ladder bygga den logiska funktionen genom att sätta ihop kontakter i olika mönster, sätter man i Logikschema ihop funktioner. Man sätter ihop exempelvis OCH- och ELLER-funktioner genom att dra streck mellan dem som indikerar vilka signaler som utbyts mellan de olika funktionerna. Man har också tillgång till Fördröjningsfunktioner, Räknefunktioner och Minnesfunktioner.

När man beskrivit önskad funktion i ett Logikschema är det ganska enkelt att översätta detta till PLC-instruktioner.


Logiska funktioner

För att få de olika styrdonen, cylindrar och motorer, att agera i rätt ögonblick måste det finnas överordnad logik som ser till detta. I moderna anläggningar finns denna logik oftast i PLC:t, Programmable Logic Controller.

Genom att bygga samman ett antal logiska funktioner kan man se till att styrdonen agerar på ett korrekt sätt. En kombination av olika logiska funktioner, INTE, OCH, ELLER, Minne och fördröjning, gör att du får styrsystemet att utföra de aktiviteter du önskar.

När man programmerar ett PLC så är det egentligen detta man gör; man bygger samman olika logiska funktioner.

JA-funktionen

OCH-funktionen

ELLER-funktionen

INTE-funktionen

Minnesfunktion

Fördröjningsfunktion

Räknefunktion


Maskinstyrning

Maskinstyrning innebär att PLC:t styr en maskin endast med ett antal digitala signaler. Med detta menas att signalerna kan anta endast två tillstånd, Till eller Från. Detta kan exempelvis vara en signal till en kontaktor som styr en. Om signalen är Till roterar motorn, om den är Från står motorn stilla. Detta förfarande är vanligast inom tillverkningsindustrin, där man styr maskiner som pressar plåt, förpackar livsmedel, trycker text på fönster etc.

De PLC som används för denna typ av styrning är av en enklare konstruktion än de som används i processtyrning.


MC-instruktionen

MC betyder Master Control. Instruktionen MC används när man har överordnade villkor. Använder man MC instruktionen kan man undvika stora programavsnitt och där igenom få en enklare programmering.

Ex. Om MC M100 blir Till utför PLC programmet de instruktioner som står mellan MC M100 och MCR M100. Om MC M100 inte blir Till hoppar PLC programmet över dessa instruktioner.


MCR-instruktionen

MCR betyder Master Control Reset. Denna instruktion skriver man sist i det block som styrs av MC-kontakten. Se även MC-instruktionen.


MINNES-funktionen i PLC-språk

Melsec FX

En Frånslagsprioriterad Minnes-funktion görs så här i Mitsubishis PLC:

LD X1

SET Y3

LD X2

RST Y3

När X1 (set-ingången) blir Till sätts utgång Y3. Även om ingång X1 sedan blir Från så förblir Y3 Till, det är detta som är minnesfunktionen.

Y3 förblir Till ända tills X2 (resetingången) blir Till. Då blir Y3 Från.

Om BÅDE X1 OCH X2 blir Till kommer Y3 att bli Från. Det är detta som gett minnet dess namn frånslagsprioriterad. Om både tillslag (set) och frånslag (reset) begärs så är frånslag prioriterat.

En Tillslagsprioriterad Minnes-funktion görs så här i Mitsubishis PLC:

LD X1

RST Y3

LD X2

SET Y3

När X1 (reset-ingången) blir Till blir utgång Y3 Från. Även om ingång X1 sedan blir Från så förblir Y3 Från, det är detta som är minnesfunktionen.

Y3 förblir Från ända tills X2 (setingången) blir Till. Då blir Y3 Till.

Om BÅDE X1 OCH X2 blir Till kommer Y3 att bli Till. Det är detta som gett minnet dess namn tillslagsprioriterad. Om både tillslag (set) och frånslag (reset) begärs så är tillslag prioriterat.

Dessa båda minnestyperna fungerar alltså likadant förutom vid ett tillfälle, om både tillslag och frånslag begärs. I detta fallet så blir utgången Till om det är ett tillslagsprioriterat minne, men Från om det är ett frånslagsprioriterat minne.

Siemens S7

En Frånslagsprioriterad Minnes-funktion görs så här i Siemens PLC:

A I0.1

S Q1.3

NET

A I0.2

R Q1.3

När I0.1 (set-ingången) blir Till sätts utgång Q1.3. Även om ingång I0.1 sedan blir Från så förblir Q1.3 Till, det är detta som är minnesfunktionen.

Q1.3 förblir Till ända tills I1.2 (resetingången) blir Till. Då blir Q1.3 Från.

Om BÅDE I0.1 OCH I0.2 blir Till kommer Q1.3 att bli Från. Det är detta som gett minnet dess namn frånslagsprioriterad. Om både tillslag (set) och frånslag (reset) begärs så är frånslag prioriterat.

En Tillslagsprioriterad Minnes-funktion görs så här i Mitsubishis PLC:

A I0.1

R Q1.3

NET

A I0.2

S Q1.3

När I0.1 (reset-ingången) blir Till blir utgång Q1.3 Från. Även om ingång I0.1 sedan blir Från så förblir Q1.3 Från, det är detta som är minnesfunktionen.

Q1.3 förblir Från ända tills I0.2 (setingången) blir Till. Då blir Q1.3 Till.

Om BÅDE I0.1 OCH I0.2 blir Till kommer Q1.3 att bli Till. Det är detta som gett minnet dess namn tillslagsprioriterad. Om både tillslag (set) och frånslag (reset) begärs så är tillslag prioriterat.

Dessa båda minnestyperna fungerar alltså likadant förutom vid ett tillfälle, om både tillslag och frånslag begärs. I detta fallet så blir utgången Till om det är ett tillslagsprioriterat minne, men Från om det är ett frånslagsprioriterat minne.


Minnesfunktion

Förutom de logiska grundfunktionerna INTE, OCH och ELLER använder man i moderna styrsystem några till. Ett exempel är minnesfunktionen. Med dess hjälp kan man få styrsystemet att minnas (komma ihåg) vad som hänt tidigare. Ibland vill man få systemet att komma ihåg att man tryckt på en knapp, och detta åstadkommer man med en minnesfunktion.

Ett minne fungerar så att dess utgång blir Till då SET-ingången påverkas, och blir Från om RESET-ingången påverkas.

Det som skiljer olika minne åt är vad som händer om både SET- och RESET-ingångarna påverkas samtidigt. Ett tillslagsprioriterat minnes utgång blir då Till, medan ett frånslagsprioriterat minnes utgång blir Från.


Modern Produktion

Högre och högre krav ställs på modern produktion. Produkterna ska ha högre kvalitet och de ska produceras på kortare och kortare tid med mindre resurser. För att åstadkomma detta mäter man många olika saker, tider, vilken kvalite produkten har, hur länge maskinen står stilla osv.


NOP-instruktionen

Ingen bearbetning sker på den raden som NOP instruktionen står på i ditt PLC program. NOP står för No OPeration.


OCH-funktion i PLC-språket

Melsec FX

En OCH- funktion i Mitsubishis PLC görs på detta sätt:

LD X3

AND X5

OUT Y4

Detta är en OCH-funktion mellan ingångarna X3 OCH X5. Om dessa bägge är Till sätts utgång Y4 Till.

Se även: LDI ANI ANB OR

Siemens S7

En OCH- funktion i Siemens PLC görs på detta sätt:

A I0.3

A I0.5

= Q1.4

Detta är en OCH-funktion mellan ingångarna I0.3 OCH I0.5. Om dessa bägge är Till sätts utgång Q1.4 Till.

Se även: AN A( O


OCH-funktionen

Denna funktion heter AND på engelska. Den innebär att man seriekopplar ingående kontakter, dvs kopplar dem efter varandra.

Ett annat sätt att uttrycka OCH-funktionens beteende är; om alla ingångarna är Till så är utgången Till, annars är den Från.


Optisk sensor

Optiska sensorer använder sig av ljus för att detektera föremål. Optiska sensorer kan arbeta på tre olika sätt:

1. Direktavkänning. Ljuset reflekteras i tillbaka till sensorn när något föremål kommer in i ljusstrålen och sensorn ändrar utsignalen. Mätavståndet är 0 - 1 m.

2. Reflekterande. I ena änden sitter sensorn och i andra änden sitter en reflektor. Reflektionen bryts när något föremål kommer in i ljusstrålen vilket får sensorn att ändra utsignalen. Mätavståndet är 0 - 10 m.

3. Sändare-Mottagare. Denna typ av sensor består av två delar. I ena änden sitter en sändare och i andra änden sitter en mottagare. Ljusstrålen bryts när något föremål kommer in i den vilket mottagaren märker och ändrar utsignalen. Mätavståndet är >50 m.

Utsignalen kan ändras på två sätt beroende på om det är en PNP- eller NPN-sensor. En PNP-sensor ger en positiv utsignal och en NPN-sensor ger en negativ. Den optiska sensorn är känslig för nedsmutsning.


OR-instruktionen, O

OR-instruktionen

OR-instruktionen är detsamma som ELLER-funktionen, och innebär att man parallellkopplar kontakterna. Ett annat sätt att uttrycka ELLER-funktionen; om alla ingångarna är Från är utgången Från, annars är den Till.

Melsec FX

Se även ORI ORB AND

Siemens S7

Se även ON O( A


ORB-instruktionen, O(

ORB-instruktionen (Melsec FX)

Denna instruktion används för att parallellkoppla de olika programblocken i ditt PLC-program.

Se även: OR ANB

O(-instruktionen (Siemens S7)

Denna instruktion används för att parallellkoppla de olika programblocken i ditt PLC-program.

Blocket avslutas med ).

Ex:

O I0.0

O(

A I0.1

A I0.2

)

= Q1.2

Se även: O A(


ORI-instruktionen, ON

ORI-instruktionen (Melsex FX)

ORI betyder OR Inverse. Om en av de parallellkopplade kontakterna INTE skall vara Till för att utgången skall bli Till använder man instruktionen ORI.

Se även: OR LDI ANI

ON- instruktionen (Siemens S7)

ON betyder Or Not. Om en av de parallellkopplade kontakterna INTE skall vara Till för att utgången skall bli Till använder man instruktionen ON.

Se även: O AN


OUT-instruktionen, =

OUT-instruktionen (Melsec FX)

Ett logiskt uttryck avslutas med instruktionen OUT. Denna instruktion används för att påverka utgångar. Om resultatet av den logiska kombinationen som satts samman är Till så kommer utgången att bli Till. I PLC:t anges detta genom att skriva OUT följt av en utgång, exempelvis Y0.

=-instruktionen (Siemens S7)

Ett logiskt uttryck avslutas med instruktionen =. Denna instruktion används för att påverka utgångar. Om resultatet av den logiska kombinationen som satts samman är Till så kommer utgången att bli Till. I PLC:t anges detta genom att skriva = följt av en utgång, exempelvis Q1.0.


Peas & Lav

För att styra hela denna anläggningen behövs 4 stycken PLC. En PLC styr förpackningsmaskinen som fyller på och tillsluter konservburkarna (sitter i ett apparatskåp i källaren), En PLC styr pallastaren, en PLC styr transportband och sortering av konservburkar och en PLC styr blandning och nedtappning av vätskan.

PLC:na sitter monterade i apparatskåp, en PLC i varje skåp.

Anledningen till att man monterar dem i apparatskåp är att de skyddas från smuts och damm men här har man också tillgång till alla de signaler som går in och ut från PLC:t. I skåpet kan man oftast utföra en stor del av felsökningsarbetet. Dessutom brukar man montera tryckknappar, visarinstrument och lampor på utsidan av apparatskåpet.

För att tillverka dessa ärtor på burk krävs en blandningstank för konserveringsmedlet, förvaringskärl för de ärtor som kommer in via lastbil, förpackningsmaskin för att förpacka ärtorna i konservburkar (finns i källaren!), transportband som transporterar burkarna till sorteringsanläggningen, förpackningsmaskin som förpackar burkarna i kartonger, pall-lastare som lastar kartongerna på trucken (pall-lastaren finns i rummet bredvid), förarlös truck som transporterar kartongerna till utlastningsporten och en gaffeltruck som flyttar kartongerna till en väntande lastbil.


PLC

Programmable Logic Controller, en industriell dator med speciell elektronik för att klara svåra miljöer. Dessutom har de ett anpassat programmeringspråk för de tillämpningar som de är satta att styra.

PLC, allmänt

PLC, fysisk miljö

PLC, ingångar

PLC portar

PLC-program

PLC, utgångar

PLC-språket

Processavbild

Programmering, symbolspråk

Programmeringsporten

Programmeringsenhet

Programmering, arbetssätt

Programmering av PLC

Resultatregister


PLC, allmänt

Ett styrsystem kan enkelt sägas bestå av tre delar; ingångar, utgångar och dess logiska regler. Genom ingångarna får styrsystemet information om vad som händer i den maskin som styrs. Informationen om detta fås via olika typer av givare. Genom utgångarna har styrsystemet möjlighet att påverka styrdonen. De logiska reglerna anger när respektive utgång ska vara Till. Reglerna kan till exempel ange; om ingång 3 är Till då ska utgång 4 vara Till. Genom att ange denna typ av regler bestämmer man styrsystemets funktion.

Det vanligaste styrsystemet idag är PLC:t, Programmable Logic Controller.


PLC, fysisk miljö

Den omgivning som PLC:t är tänkt att arbeta i ställer stora krav på apparaterna. Alltifrån den fysiska miljön, såsom damm och fukt, till den elektriska miljön. Den sistnämnda kan ställa till mycket bekymmer. Magnetfält, störningar på nätspänningen kan vara mycket störande för alla apparater som ska verka i denna miljö.

En del av dessa faktorer kan undvikas genom att man monterar apparaterna i särskilda apparatskåp. På så sätt kan den fysiska miljön förbättras. Dock måste apparaten i sig vara förberedd för att hantera de eventuella elektriska störningarna som kan uppkomma. Just denna bit är viktig för ett industriellt styrsystem.

För att undvika problem som kommer utav att felaktiga signaler ges till PLC:t, är den försedd med speciell elektronik på ingångssidan. Elektroniken består bland annat av kretsar som kallas optokopplare. Dessa gör om elektrisk spänning till en ljussignal. På detta sätt får vi vad man kallar för en galvanisk isolering. Det innebär bland annat att om en felaktig signal kommer in på en ingång tjänstgör optokopplaren som ett skydd.

Ingångselektronikens uppgift är att förse PLC:t med information om vilket tillstånd de olika insignalerna har.


PLC, ingångar

Via ingångarna tar PLC:et mot de insignaler som kommer från den styrda maskinen. Insignalerna kopplas direkt till ingångarna via plintar monterade på PLC:et. Insignalerna kommer oftast från någon typ av givare som har slutande kontakt.

När kontakten slutes flyter det en ström till ingången på PLC:et, som detekterar detta. Ingången är påverkad (ett-ställd). Den slutna strömkretsen fås genom att ansluta spänningsaggregatets minuspol till plinten 0V på PLC:et.

En del PLC har egen spänningskälla, vilket gör att man kan låta denna driva strömmen till ingångarna. I större anläggningar använder man dock normalt en extern spänningskälla.

Beroende på vilket PLC man valt har man olika många ingångar. De minsta PLC:erna har kanske 8 ingångar, medan de allra största kan ha flera tusen.


PLC, utgångar

Med utgångarna styr PLC:t sin omgivning. Genom att sätta dessa Till eller Från kan PLC:t starta motorer, styra cylindrar etc. Oftast sitter det något styrdon monterat mellan PLC:t och motorn eller cylindern. För att styra en cylinder krävs en magnetventil och för att styra en motor krävs en kontaktor eller ett relä.

Utgångarna matas från ett externt spänningsaggregat. När det interna reläet i PLC:t ett-ställs av PLC-programmet flyter strömmen genom detta reläet och genom det styrdon som är kopplat till utgången.

De minsta PLC:na har några få utgångar, kanske 4 stycken, medan de största kan ha flera tusen.

Utgångselektroniken har som uppgift att se till att PLC:t ger riktiga utsignaler från sig.

Denna elektronik består vanligen av någon av följande konstruktion:

l Relä-utgångar, den vanligaste typen

l Transistor-utgångar

l Triac-utgångar

PLC:ts reläer styrs alltså av elektroniken som sköter bearbetningen av programmet i PLC:t. När denna ger order så drages reläet för begärd utgång och en utsignal ges. Dock måste den som har installerat PLC:t se till att varje utgång är matad med önskvärd spänning. I vårt fall använder vi enbart 24V DC.


PLC-program

Inuti PLC:t finns det program som någon har matat in. Detta program körs av PLC:t och bestämmer när respektive utgång ska vara Till eller Från.
Programmet kan matas in på två olika sätt; antingen med hjälp av en dator eller med hjälp av en handhållen programmeringsenhet.
Det finns en omkopplare på fronten av PLC:t. Med denna kan man tala om för PLC:t om det ska arbeta eller inte. Ställer man brytaren i läge RUN, så innebär det att PLC:t kör det program som man matat in. Ställer man brytaren i läge STOP så gör PLC:t ingenting.


PLC-språket

Hur kan dessa funktioner programmeras in i ett PLC? För att göra detta måste vi lära oss lite om "PLC-språket", dvs det språk som PLC:t använder. Detta bygger på de funktioner vi nämnt tidigare, men är helt olikt det språk som vi människor pratar.

För att göra denna översättning enklare brukar man använda olika symbolspråk. Ett exempel på ett sådant symbolspråk är Ladderschema. Med hjälp av Ladderschema kan man rita ihop en logisk beskrivning som sedan är ganska lätt att översätta till PLC-program.

Ett annat symbolspråk är Logikschema. Detta är ett annat sätt att beskriva de logiska funktioner som vi tidigare tittat på. Översättning från Logikschema till PLC-program är förhållandevis enkel.


PLC portar

Med port menas i detta sammanhang vilka vägar som PLC:t har för att utbyta information med sin omgivning. Det finns i huvudsak tre:

l Ingångar, som tar emot insignaler från sensorer

l Utgångar, som ger utsignaler till styrdon

l Programmeringsporten, där vi skriver in det program som ska utföras av PLC:t

Dessutom finns det på moderna PLC också olika möjligheter att kommunicera med andra PLC:er och datorer. Antal in- och utgångar varierar mellan något tiotal till flera tusen per PLC.


PLF-instruktionen

PLF-instruktionen (Melsec FX)

Instruktionen PLF används för att ge en puls till en minnescell eller utgång. PLF reagerar endast på en negativ flank, dvs när det blir en förändring från 1 till 0.


PLS-instruktionen

PLS-instruktionen (Melsec FX)

Instruktionen PLS används för att ge en puls till en minnescell eller utgång. PLS reagerar endast på en positiv flank, dvs när det blir en förändring från 0 till 1.


Pneumatiskt schema

Ett standardiserat sätt att beskriva hur olika pneumatiska komponenter är kopplade till varandra.


Processavbild

Intern minnesarea som innehåller minnesceller för alla in- och utgångar. Varje in- eller utgång har en egen minnescell i denna area.


Processtyrning

Med processtyrning menas att PLC:t styr sin omgivning även med hjälp av analoga signaler. Dessa signaler kan anta ett, oftast flera tusen, olika tillstånd. Exempel på en analog signal är en signal som indikerar nivån i en tank. Om tanken är full är signalen 20 mA, om tanken är tom är signalen 0 mA. Men om nivån i tanken är någonstans mellan dessa två ytterligheter är signalen det också. Om tanken är full till 25% är signalen 5 mA. Signalen följer alltså nivån i tanken hela tiden.

De PLC som används i processtyrning har oftast också funktioner för styrning av stegmotorer, servosystem och liknande. Det bör påpekas att det är svårt att dra en klar linje mellan maskinstyrning och processtyrning. I enkla fall består en styrning kanske enbart av maskinstyrnings-funktioner, men en större styrning består oftast av båda typerna av styrning.


Programkonstruktion

En gyllene regel: Tänk först, programmera sedan! Detta betyder att du ska fundera igenom problemet först, sedan göra din funktionsbeskrivning i Ladder-schema, Funktionsblocksschema eller något annat. Först därefter är det dags att börja skriva programmet.

Ju mer strukturerat du gör ditt program, ju större är chansen att du fortast möjligt kommer fram till korrekt PLC-program.


Programmering, arbetssätt

Vid programmering av ett PLC är arbetsordningen:

1. Rita ned de regler du vill ska gälla för PLC:t. Detta gör du antingen genom att rita ett Ladderschema eller ett Funktionsblocksschema.

2. Översätt detta till PLC-program. För att programmera ett PLC måste vi "översätta" från vårt mänskliga språk till det språk som PLC:t använder.

3. Mata in detta i PLC:t och provkör.

4. Gör eventuella ändringar om det behövs.

5. Dokumentera det du gjort, dvs skriv ut programmet på papper, spara det på diskett etc.


Programmering, symbolspråk

När man skall programmera ett PLC måste man bestämma hur det skall arbeta, detta kan göras i olika symbolspråk. Ett exempel på ett sådant symbolspråk är Ladderschema. Med hjälp av Ladderschema kan man rita ihop en logisk beskrivning som sedan är ganska lätt att översätta till PLC-program.

Ett annat symbolspråk är Logikschema. Detta är ett annat sätt att beskriva de logiska funktioner. Översättning från Logikschema till PLC-program är förhållandevis enkel.

Vid programmering av ett PLC är alltså arbetsordningen:

l Rita ned de regler du vill ska gälla för PLC:t. Detta gör du antingen genom att rita ett Ladderschema eller ett Logikschema.

l Översätt detta till PLC-program.

l Mata in detta i PLC:t och provkör.

Om det inte fungerar som du tänkt så ändrar du programmet och provkör igen!


Programmering av PLC

För att kunna berätta för PLC:t vad det skall göra måste du behärska dess språk. Det finns några olika men funktionerna i är i stort sett samma.

Grundfunktionerna, som har funnits med ända sedan 60-talet, är de vanliga logiska funktionerna OCH, ELLER samt INTE. Med dessa kan man lösa ALLA logiska problem. På 70-talet kom ytterligare tre funktioner till nämligen MINNE, TIDSFÖRDRÖJNINGAR samt RÄKNARE.

Med dessa sex funktionerna kan man lösa de flesta enkla automatiseringsproblem.

ELLER-funktionen i PLC-språk

Fördröjnings-funktionen i PLC-språk

INTE-funktionen i PLC-språk

MINNES-funktionen i PLC-språk

OCH-funktion i PLC-språket

Räkne-funktionen i PLC-språk

Melsec FX Siemens S7

ANB-instruktinen A(

AND-instruktionen A

ANI-instruktionen AN

END-instruktionen

LD-instruktionen A,O

LDI-instruktionen AN,ON

MC-instruktionen

MCR-instruktionen

NOP-instruktionen

OUT-instruktionen =

OR-instruktionen O

ORB-instruktionen O(

ORI-instruktionen ON

PLF-instruktionen

PLS-instruktionen

RST-instruktionen S

SET-instruktionen R


Programmering via PC

Ett annat sätt att mata in PLC-programmet i PLC:t är att först skriva PLC-programmet på en PC, och sedan överföra det till PLC:t.

Med hjälp av PC-programmet kan man utveckla och prova PLC-programmet. Detta gör att man får en bättre överblick och att man snabbare kan utveckla och prova PLC-programmet.


Programmeringsenhet

PLC:t sköter arbetet med att styra och ställa. Detta arbete ska utföras utifrån två saker:

l Det program som finns i PLC:t

l De insignaler som ges till PLC:t

Programmet som finns i PLC:t skrivs av oss. För att göra detta måste vi kunna kommunicera med centralenheten. Därför har ett komplett PLC också en programmeringsenhet. Med denna är det möjligt för oss att förse PLC:t med ett program.

Programmeringsenheten är i sig en liten dator. Dess uppgift är att kommunicera med PLC:t.

Genom att först mata in ditt program via programmeringsenheten, och sedan starta programmet, får du PLC:t att utföra det du vill.


Programmeringsporten

Denna kontakt, som sitter ovanpå PLC:t, används för att kommunicera med omvärlden.

Till denna kan man ansluta:

l Programmeringsenhet

l PC-dator

Med programmeringsenhetens hjälp matar man in de programinstruktioner man önskar i PLC:t. Ett annat sätt att göra samma sak är att använda ett program i en dator (PC). Med detta programs hjälp skriver man PLC-programmet och sedan överför man detta till PLC:t via programmeringsporten.


Räkne-funktionen i PLC-språk

Melsec FX

Räkne-funktionen görs så här i Mitsubishi PLC:

LD X4

RST C1

LD X2

OUT C1

K5

LD C1

OUT Y3

Ingången X4 gör att räknaren C1 nollställs, dvs dess ärvärde blir 0. Varje gång som ingång X2 blir Till räknar C1 upp med 1. Efter att X2 blivit Till 5 gånger (anges med K5 efter räknarens namn i programmet) blir räknarens utgång Till. I programmet har vi angett att om C1 blir Till ska Y3 bli Till.

Siemens S7

Räkne-funktionen görs så här i Siemens PLC:

A I0.4 (Preset ingång)

L C#5 (antal gånger)

S C1 (räknare 1)

NET

A I0.2 (Räkne ingång)

CD C1

NET

AN C1

OUT Q1.3

Ingången I0.4 gör att räknaren C1 laddas med värdet 5. Varje gång som ingång I0.2 blir Till räknar C1 ner med 1. Efter att I0.2 blivit Till 5 gånger blir räknarens utgång Från. I programmet har vi angett att om C1 blir Från ska Q1.3 bli Till.


Räknefunktion

En funktion i PLC:t som används till att räkna exempelvis hur många gånger en ingång blivit Till. Om man exempelvis vill att utgång 2 ska bli Till när ingång 4 har blivit Till 3 gånger så använder man en räknare. Genom att tala om för räknaren att den ska räkna hur många gånger ingång 4 har blivit Till, och sedan testa av om räknaren har räknat färdigt, kan man få utgång 2 att bli Till i rätt ögonblick. På engelska kallas denna funktion för Counter.


Resultatregister

Resultatregister (RLO i Siemens)

När PLC:t kör sitt program, i steg 2 i den cykliska bearbetningen, utför den instruktion för instruktion. Från början till slut. Resultatet av varje instruktion hamnar i resultatregistret.

Om exempelvis en OCH-funktion ska utföras kan programmet se ut så här:

LD X3

AND X6

OUT Y31

I detta fallet utförs först instruktionen LD X3 och resultatet av denna instruktion hamnar i resultatregistret. Om ingång X3 är Till hamnar en 1:a i registret, om den är Från hamnar en 0:a där.

Sedan utförs instruktionen AND X6. Detta är en OCH-funktion, vilket alltså innebär att det måste finnas två signaler att utföra funktionen på. Det PLC:t gör är att göra en OCH-funktion mellan resultatregistret (där resultatet från första instruktionen ligger) och X6. Resultatet av denna funktionen hamnar i resultatregistret.

När sedan sista instruktionen, OUT Y31, utförs, hämtas bara innehållet i resultatregistret. Ligger där en 1:a läggs en 1: i minnescellen för utgång Y31. Denna minnescell finns i processavbilden. Ligger där en 0:a läggs en 0:a i minnescellen.

När sedan 3:e steget i PLC:ts cykliska bearbetning utförs, utläsning till utgångarna, sätts de utgångar som har en 1:a i sin minnescell. De utgångar som har en 0:a i sin minnescell blir däremot Från.


Riktningsventil

Används för att styra cylindrars rörelser. Genom att styra luften till någon av cylindrarnas kammare får man cylindern att röra sig i någondera riktning. Det finns olika typer av ventiler, en del för att styra dubbelverkande cylindrar, en del för att styra enkelverkande cylindrar.

De som styr dubbelverkande cylindrar brukar kallas bistabila eftersom de stannar kvar i det läge man begärt. De som styr enkelverkande brukar kallas unistabila eftersom de bara har ett stabilt läge.


RST-instruktionen, R

RST-instruktionen (Melsec FX)

RST används för att återställa räknare , skiftregister och minnen . RST är Till så länge det logiska villkoret som styr denna är uppfyllt.

R-instruktionen (Siemens S7)

R används för att återställa minnen . R är Till så länge det logiska villkoret som styr denna är uppfyllt.


Säkerhet i PLC-program

Med säkerhet i PLC-program menar vi att man måste ta hänsyn till personskydd och maskinskydd när man skriver sitt PLC-program. Detta betyder att man tänker på att programmet inte kan göra några felfunktioner som skadar människor eller maskiner, men också att man försöker räkna ut alla de felfunktioner som kan inträffa och förreglar bort dessa.


Sekvensproblem

Detta namn brukar man använda på de styrproblem som ska styras i sekvens, dvs där händelser ska utföras i en speciell ordning. Först ska exempelvis motor 1 startas, sedan ska motor 2 startas osv.


Sensorer

Induktiv sensor

Kapacitiv sensor

Optisk sensor


Symbolspråk, användningsområden

Ett Ladderschema är mycket bra på att beskriva hur olika ingångar hänger ihop, dvs vilka logiska funktioner som ska utföras mellan ingångarna. Däremot är Ladder mindre bra på att visa hur ett stort program är sammansatt. Om programmet består av flera hundra PLC-instruktioner, vilket inte är ovanligt, så blir överblicken dålig.
Då är logikschema betydligt bättre på att beskriva hur ett stort program hänger ihop.


Tillslagsfördröjning

Tillslagsfördröjning innebär exempelvis att Tillslaget på en utgång fördröjs. Exempel: om man vill att utgång Y3 ska bli Till 5 sekunder efter det att ingång X2 har blivit Till, ska man använda en Tillslagsfördröjning.


Tillverkning

Industriell tillverkning består av många olika saker, här följer några av de vanligaste handhavanden:

Blandning av olika vätskor eller torrvaror

Styrning av kemiska processer, exempelvis framställning av saltsyra

Mekanisk bearbetning, exempelvis svarvning

Transport av materiel, exempelvis på ett transportband

Torkning av materiel, exempelvis torkning av pappersmassa

Sortering av olika varor, eller i vissa fall sortera bort felaktiga varor

Förpackning av varor, exempelvis i säckar eller i burkar

För att göra alla dessa saker behövs olika maskiner och utrustningar. Det behövs transportband, blandningskärl, svarvar, torkutrustning, förpackningsmaskiner etc.

Och om dessa maskiner och utrustningar ska kunna utföra sitt arbete på ett riktigt sätt så behöver de styras. Här kommer automationen in!


Trafikljus

Melsec FX Siemens S7

Ingångar Kommentar

X0 I0.0 Tryckknapp för fotgängare bortre

X1 I0.1 Tryckknapp för fotgängare hitre

X3 I0.3 Magnetslinga för bilar hitre

X4 I0.4 Magnetslinga för bilar bortre

Utgångar Kommentar

Y0 Q1.0 Grönt ljus för bilar

Y1 Q1.1 Gult ljus för bilar

Y2 Q1.2 Rött ljus för bilar

Y3 Q1.3 Rött ljus för fotgängare

Y4 Q1.4 Grönt ljus för fotgängare